using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\h*([^\w\s](?:\h+[^\w\s])*)\h*";
string substitution = @"$1 $2 ";
string input = @"test! one.two .three; four, five . six. .seven";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}