use strict;
my $str = 'test! one.two .three; four, five . six. .seven';
my $regex = qr/(\w+)\h*([^\w\s](?:\h+[^\w\s])*)\h*/mp;
my $subst = '$1 $2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";