package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\-?\d+\.?\d*|\-?\.\d+|\-?\.?\d+[eE]\-?\d+|-?\d+\.?\d*[eE]\d+)($|[a-z]*$)`)
var str = `00
0
-0
0.
.0ns
12.3ps
12.34minute
-12.34
10E40sd
10e40sd
1E4
1E-4hours
-10E40nanosecond
-10E-40
-.1E-4
10.2E30
10.2e30
.10E30
-10.2E30
-.10E30
# wrong numbers
12.34 # with comment
12.34.12fdsfdsfds
1E4.4
.10E30E
10.2.E30
123#with wrong comment
E10
.E10
-e
-E10
10-10E19`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}