import Foundation
let pattern = #"^(\-?\d+\.?\d*|\-?\.\d+|\-?\.?\d+[eE]\-?\d+|-?\d+\.?\d*[eE]\d+)($|[a-z]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
00
0
-0
0.
.0ns
12.3ps
12.34minute
-12.34
10E40sd
10e40sd
1E4
1E-4hours
-10E40nanosecond
-10E-40
-.1E-4
10.2E30
10.2e30
.10E30
-10.2E30
-.10E30
# wrong numbers
12.34 # with comment
12.34.12fdsfdsfds
1E4.4
.10E30E
10.2.E30
123#with wrong comment
E10
.E10
-e
-E10
10-10E19
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)