import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\-?\\d+\\.?\\d*|\\-?\\.\\d+|\\-?\\.?\\d+[eE]\\-?\\d+|-?\\d+\\.?\\d*[eE]\\d+)($|[a-z]*$)";
final String string = "00\n"
+ "0\n"
+ "-0\n"
+ "0.\n"
+ ".0ns\n"
+ "12.3ps\n"
+ "12.34minute\n"
+ "-12.34\n"
+ "10E40sd\n"
+ "10e40sd\n"
+ "1E4\n"
+ "1E-4hours\n"
+ "-10E40nanosecond\n"
+ "-10E-40\n"
+ "-.1E-4\n"
+ "10.2E30\n"
+ "10.2e30\n"
+ ".10E30\n"
+ "-10.2E30\n"
+ "-.10E30\n\n"
+ "# wrong numbers\n"
+ "12.34 # with comment\n"
+ "12.34.12fdsfdsfds\n"
+ "1E4.4\n"
+ ".10E30E\n"
+ "10.2.E30\n"
+ "123#with wrong comment\n"
+ "E10\n"
+ ".E10\n"
+ "-e\n"
+ "-E10\n"
+ "10-10E19";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}