# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\-?\d+\.?\d*|\-?\.\d+|\-?\.?\d+[eE]\-?\d+|-?\d+\.?\d*[eE]\d+)($|[a-z]*$)"
test_str = ("00\n"
"0\n"
"-0\n"
"0.\n"
".0ns\n"
"12.3ps\n"
"12.34minute\n"
"-12.34\n"
"10E40sd\n"
"10e40sd\n"
"1E4\n"
"1E-4hours\n"
"-10E40nanosecond\n"
"-10E-40\n"
"-.1E-4\n"
"10.2E30\n"
"10.2e30\n"
".10E30\n"
"-10.2E30\n"
"-.10E30\n\n"
"# wrong numbers\n"
"12.34 # with comment\n"
"12.34.12fdsfdsfds\n"
"1E4.4\n"
".10E30E\n"
"10.2.E30\n"
"123#with wrong comment\n"
"E10\n"
".E10\n"
"-e\n"
"-E10\n"
"10-10E19")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.