const regex = /^(\-?\d+\.?\d*|\-?\.\d+|\-?\.?\d+[eE]\-?\d+|-?\d+\.?\d*[eE]\d+)($|[a-z]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\-?\\d+\\.?\\d*|\\-?\\.\\d+|\\-?\\.?\\d+[eE]\\-?\\d+|-?\\d+\\.?\\d*[eE]\\d+)($|[a-z]*$)', 'gm')
const str = `00
0
-0
0.
.0ns
12.3ps
12.34minute
-12.34
10E40sd
10e40sd
1E4
1E-4hours
-10E40nanosecond
-10E-40
-.1E-4
10.2E30
10.2e30
.10E30
-10.2E30
-.10E30
# wrong numbers
12.34 # with comment
12.34.12fdsfdsfds
1E4.4
.10E30E
10.2.E30
123#with wrong comment
E10
.E10
-e
-E10
10-10E19`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}