#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\*)[^*]+\R(?=\*)"
Local $sString = "********** Field #1 **********" & @CRLF & _
"Content inside Field #1" & @CRLF & _
"More content" & @CRLF & _
"" & @CRLF & _
"********** Field #2 **********" & @CRLF & _
"Content inside Field #2" & @CRLF & _
"More content" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
"********** The last field will always remain unchanged **********" & @CRLF & _
"Unchanged content from last field"
Local $sSubst = "\n[REPLACEMENT]\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)