import Foundation
let pattern = #"(?<=\*)[^*]+\R(?=\*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
...
********** The last field will always remain unchanged **********
Unchanged content from last field
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n[REPLACEMENT]\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)