use strict;
my $str = '********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
...
********** The last field will always remain unchanged **********
Unchanged content from last field';
my $regex = qr/(?<=\*)[^*]+\R(?=\*)/mp;
my $subst = '\\n[REPLACEMENT]\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";