import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\*)[^*]+\\R(?=\\*)";
final String string = "********** Field #1 **********\n"
+ "Content inside Field #1\n"
+ "More content\n\n"
+ "********** Field #2 **********\n"
+ "Content inside Field #2\n"
+ "More content\n\n"
+ "...\n\n"
+ "********** The last field will always remain unchanged **********\n"
+ "Unchanged content from last field";
final String subst = "\\n[REPLACEMENT]\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}