# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\*)[^*]+\R(?=\*)"
test_str = ("********** Field #1 **********\n"
"Content inside Field #1\n"
"More content\n\n"
"********** Field #2 **********\n"
"Content inside Field #2\n"
"More content\n\n"
"...\n\n"
"********** The last field will always remain unchanged **********\n"
"Unchanged content from last field")
subst = "\\n[REPLACEMENT]\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.