using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d+\.\d+\,){123}(\d+\.\d+)";
string input = @"1516924800000,0.00063951,0.00063997,0.00063339,0.00063388,1145.00000000,1517011199999,0.72784872,53,453.00000000,0.28847478,0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}