re = /^(?:\d+\.\d+\,){123}(\d+\.\d+)/
str = '1516924800000,0.00063951,0.00063997,0.00063339,0.00063388,1145.00000000,1517011199999,0.72784872,53,453.00000000,0.28847478,0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end