import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+\\.\\d+\\,){123}(\\d+\\.\\d+)";
final String string = "1516924800000,0.00063951,0.00063997,0.00063339,0.00063388,1145.00000000,1517011199999,0.72784872,53,453.00000000,0.28847478,0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}