const regex = /<div>.*<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div>.*<\\\/div>', 'gm')
const str = `<div>你好</div>
<div>表示该字符开头
.表示匹配任意字符(除换行符)
*表示任意几位
\\转义符,因为/有其特殊意义
</div>表示以该字符结尾`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}