// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<div>.*<\/div>").unwrap();
let string = "<div>你好</div>
<div>表示该字符开头
.表示匹配任意字符(除换行符)
*表示任意几位
\\转义符,因为/有其特殊意义
</div>表示以该字符结尾";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}