$re = '/<div>.*<\/div>/m';
$str = '<div>你好</div>
<div>表示该字符开头
.表示匹配任意字符(除换行符)
*表示任意几位
\\转义符,因为/有其特殊意义
</div>表示以该字符结尾';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);