use strict;
my $str = '<div>你好</div>
<div>表示该字符开头
.表示匹配任意字符(除换行符)
*表示任意几位
\\转义符,因为/有其特殊意义
</div>表示以该字符结尾';
my $regex = qr/<div>.*<\/div>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}