re = /<div>.*<\/div>/m
str = '<div>你好</div>
<div>表示该字符开头
.表示匹配任意字符(除换行符)
*表示任意几位
\\转义符,因为/有其特殊意义
</div>表示以该字符结尾'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end