using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\da-z])(?:([a-z]+(?=\d)|\d+(?=[a-z]))((?<=\d)[a-z]+|(?<=[a-z])\d+))(?![\da-z])";
string substitution = @"$1 $2";
string input = @"abc21"" or ""943xyz
""a12bc"",
""11a12bc"", ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}