import Foundation
let pattern = #"(?<![\da-z])(?:([a-z]+(?=\d)|\d+(?=[a-z]))((?<=\d)[a-z]+|(?<=[a-z])\d+))(?![\da-z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abc21" or "943xyz
"a12bc",
"11a12bc",
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)