re = /(?<![\da-z])(?:([a-z]+(?=\d)|\d+(?=[a-z]))((?<=\d)[a-z]+|(?<=[a-z])\d+))(?![\da-z])/
str = 'abc21" or "943xyz
"a12bc",
"11a12bc", '
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result