const regex = new RegExp('(?<![\\da-z])(?:([a-z]+(?=\\d)|\\d+(?=[a-z]))((?<=\\d)[a-z]+|(?<=[a-z])\\d+))(?![\\da-z])', 'g')
const str = `abc21" or "943xyz
"a12bc",
"11a12bc", `;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);