import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\da-z])(?:([a-z]+(?=\\d)|\\d+(?=[a-z]))((?<=\\d)[a-z]+|(?<=[a-z])\\d+))(?![\\da-z])";
final String string = "abc21\" or \"943xyz\n\n"
+ " \"a12bc\", \n\n"
+ " \"11a12bc\", ";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}