using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{4})([0-9]{2})([0-9]{2})";
string input = @"FortiAuthenticator_FACVM-v6.0.3-build0058_270520-0030.conf
SYS_FMG-VMTM19006090_FMG-VM64_20200527_0030.dat
SYS_FMG-VMTM19005936_VPN-MANAGER_20200527_0030.dat";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}