use strict;
my $str = 'FortiAuthenticator_FACVM-v6.0.3-build0058_270520-0030.conf
SYS_FMG-VMTM19006090_FMG-VM64_20200527_0030.dat
SYS_FMG-VMTM19005936_VPN-MANAGER_20200527_0030.dat';
my $regex = qr/([0-9]{4})([0-9]{2})([0-9]{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}