$re = '/([0-9]{4})([0-9]{2})([0-9]{2})/m';
$str = 'FortiAuthenticator_FACVM-v6.0.3-build0058_270520-0030.conf
SYS_FMG-VMTM19006090_FMG-VM64_20200527_0030.dat
SYS_FMG-VMTM19005936_VPN-MANAGER_20200527_0030.dat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);