import Foundation
let pattern = #"([0-9]{4})([0-9]{2})([0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
FortiAuthenticator_FACVM-v6.0.3-build0058_270520-0030.conf
SYS_FMG-VMTM19006090_FMG-VM64_20200527_0030.dat
SYS_FMG-VMTM19005936_VPN-MANAGER_20200527_0030.dat
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)