package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{4})([0-9]{2})([0-9]{2})`)
var str = `FortiAuthenticator_FACVM-v6.0.3-build0058_270520-0030.conf
SYS_FMG-VMTM19006090_FMG-VM64_20200527_0030.dat
SYS_FMG-VMTM19005936_VPN-MANAGER_20200527_0030.dat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}