using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"weeks?\h*\K0+(?=[1-9]\d*[a-zA-Z])";
string substitution = @"";
string input = @"week 01st
weeks 02nd
year2022week01st
week 4th";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}