const regex = /weeks?\h*\K0+(?=[1-9]\d*[a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('weeks?\\h*\\K0+(?=[1-9]\\d*[a-zA-Z])', 'gm')
const str = `week 01st
weeks 02nd
year2022week01st
week 4th`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);