re = /weeks?\h*\K0+(?=[1-9]\d*[a-zA-Z])/m
str = 'week 01st
weeks 02nd
year2022week01st
week 4th'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result