use strict;
my $str = 'week 01st
weeks 02nd
year2022week01st
week 4th';
my $regex = qr/weeks?\h*\K0+(?=[1-9]\d*[a-zA-Z])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";