using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@)\w+";
string input = @"@mickey test new @mickey_mouse
@johndoe_
@john99
@JOHN_23
// Also included
@9gag
@_test
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}