$re = '/(?<=@)\w+/';
$str = '@mickey test new @mickey_mouse
@johndoe_
@john99
@JOHN_23
// Also included
@9gag
@_test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);