re = /(?<=@)\w+/
str = '@mickey test new @mickey_mouse
@johndoe_
@john99
@JOHN_23
// Also included
@9gag
@_test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end