import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=@)\\w+";
final String string = "@mickey test new @mickey_mouse\n"
+ "@johndoe_\n"
+ "@john99\n"
+ "@JOHN_23\n\n\n\n"
+ "// Also included\n"
+ "@9gag \n"
+ "@_test\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}