import re
regex = re.compile(r"(?<=@)\w+")
test_str = ("@mickey test new @mickey_mouse\n"
"@johndoe_\n"
"@john99\n"
"@JOHN_23\n\n\n\n"
"// Also included\n"
"@9gag \n"
"@_test\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")