# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*(.*?)\s*$/$1/gm;t' <<< " text1 text2
text3
text4
"