$re = '/^\s*(.*?)\s*$/m';
$str = ' text1 text2
text3
text4
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;