use strict;
my $str = ' text1 text2
text3
text4
';
my $regex = qr/^\s*(.*?)\s*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";