const regex = /^\s*(.*?)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(.*?)\\s*$', 'gm')
const str = ` text1 text2
text3
text4
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);