package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(.*?)\s*$`)
var str = ` text1 text2
text3
text4
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}