#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(NT\$|SAR)\s(\d{2,5})|\d{1,4}([.,]\d{3})*([\s.,]\d{2,3}|[^\W]\d+(\d{1,4})*\s(kr|zł|Pesos|Kč|Ft|บาท|SAR|₪))"
Local $sString = "Everything Matches" & @CRLF & _
"" & @CRLF & _
"1.4">$19.99" & @CRLF & _
"1.4">R$20.00" & @CRLF & _
"1.4">20.00€" & @CRLF & _
"1.4">€25,99" & @CRLF & _
"1.4">£15.99" & @CRLF & _
"1.4">123 kr" & @CRLF & _
"1.4">1234 Ft" & @CRLF & _
"1.4">999 Pesos" & @CRLF & _
"" & @CRLF & _
"but my output will look like:" & @CRLF & _
"" & @CRLF & _
"$19.99" & @CRLF & _
"R$20.00" & @CRLF & _
"20.00€" & @CRLF & _
"€25,99" & @CRLF & _
"£15.99" & @CRLF & _
"123 kr" & @CRLF & _
"1234 Ft" & @CRLF & _
"999 Pesos"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")