import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(NT\\$|SAR)\\s(\\d{2,5})|\\d{1,4}([.,]\\d{3})*([\\s.,]\\d{2,3}|[^\\W]\\d+(\\d{1,4})*\\s(kr|zł|Pesos|Kč|Ft|บาท|SAR|₪))";
final String string = "Everything Matches\n\n"
+ "1.4\">$19.99\n"
+ "1.4\">R$20.00\n"
+ "1.4\">20.00€\n"
+ "1.4\">€25,99\n"
+ "1.4\">£15.99\n"
+ "1.4\">123 kr\n"
+ "1.4\">1234 Ft\n"
+ "1.4\">999 Pesos\n\n"
+ "but my output will look like:\n\n"
+ "$19.99\n"
+ "R$20.00\n"
+ "20.00€\n"
+ "€25,99\n"
+ "£15.99\n"
+ "123 kr\n"
+ "1234 Ft\n"
+ "999 Pesos";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}