const regex = /(NT\$|SAR)\s(\d{2,5})|\d{1,4}([.,]\d{3})*([\s.,]\d{2,3}|[^\W]\d+(\d{1,4})*\s(kr|zł|Pesos|Kč|Ft|บาท|SAR|₪))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(NT\\$|SAR)\\s(\\d{2,5})|\\d{1,4}([.,]\\d{3})*([\\s.,]\\d{2,3}|[^\\W]\\d+(\\d{1,4})*\\s(kr|zł|Pesos|Kč|Ft|บาท|SAR|₪))', 'g')
const str = `Everything Matches
1.4">\$19.99
1.4">R\$20.00
1.4">20.00€
1.4">€25,99
1.4">£15.99
1.4">123 kr
1.4">1234 Ft
1.4">999 Pesos
but my output will look like:
\$19.99
R\$20.00
20.00€
€25,99
£15.99
123 kr
1234 Ft
999 Pesos`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}