using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""?([^\""]*)\""? \""?([^\""]*)\""? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})";
string substitution = @"";
string input = @"""Mattias Asplund"" 46 35000.00 070-6186120";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}