const regex = /\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"?([^\\""]*)\\"? \\"?([^\\""]*)\\"? (\\d{2}) (\\d{5}).(\\d{2}) (\\d{3}-\\d{7})', 'g')
const str = `"Mattias Asplund" 46 35000.00 070-6186120`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);