re = /\"?([^\""]*)\"? \"?([^\""]*)\"? (\d{2}) (\d{5}).(\d{2}) (\d{3}-\d{7})/
str = '"Mattias Asplund" 46 35000.00 070-6186120'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result